MT7620 OpenWrt中ap client的配置方法

2863

以下方法来自WRTnode罗老师

由于在预览版中apcli还未配置进入luci界面
这个阶段的apcli的配置需要手动完成:

0、上级路由开通DHCP服务
1、ssh登陆到WRTnode
2、输入aps,扫描当前可用ap
3、输入vw命令(vw是vi /etc/config/wireless的快捷命令)初始内容如下:

config wifi-device  ra0
        option type     ralink
        option mode     9
        option channel  6
        option txpower 100
        option ht 20+40
        option country US
# REMOVE THIS LINE TO ENABLE WIFI:
        option disabled 0

config wifi-iface
        option device   ra0
        option network  lan
        option mode     ap
        option ssid     WRTnode2070
        option encryption none
        option ApCliEnable '1'
        option ApCliSsid 'aAP'
        option ApCliAuthMode 'WPA2PSK'
        option ApCliEncrypType 'AES'
        option ApCliPassWord '87654321'

参数说明:
ApCliEnable 1为开启apcli,0为关闭
ApCliSsid 需要上联的ap ssid
ApCliAuthMode 上级ap的认证方式,可选项为:
WEPAUTO
SHARED
WPAPSK
WPA2PSK
OPEN
请根据实际上级ap认证方式填入此参数
ApCliEncrypType 上级ap的加密方式,可选项为:
WEP
TKIP
AES
请根据实际上级ap加密方式填入此参数
ApCliPassWord 上级ap的密码,明文写入。
注意,还需修改channel参数与上级ap一致
还需注意,WRTnode lan口ip网段必须与上级ap网段不同,如上级ap网段为192.168.1.x网段,WRTnode则需要改为192.168.1.x之外的其他网段。
修改网段可在luci web页面中进行,也可以在终端中输入vn命令(vi /etc/config/network的快捷命令)
在如下部分:

config interface 'lan'
        option ifanme 'ra0'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

将ipaddr参数改为你需要的网段ip地址,如192.168.8.1

4、重启网络模块,输入nr命令(nr:/etc/ini.d/network restart 的快捷命令)
5、输入ia命令(ia:ifconfig apcli0),如果显示已经取得IPv4地址,即说明连接成功。如:

apcli0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          inet addr:192.168.43.160  Bcast:192.168.43.255  Mask:255.255.255.0
          inet6 addr: xxxx::x:xxxx:xxxx:xxxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

WRTnode已经在上级路由取得了192.168.43.160 IP地址。

原文地址:cn.wrtnode.com/?topic=预览版固件中apcli的配置方法

留下一个答复

Please enter your comment!
Please enter your name here